To configure the switch to use the in-band connections (front panel Ethernet ports), an IP address is assigned to a VLAN. By default, all IPs can access the management console of the Dell EMC switch.
The commands for setting up a management VLAN often depend on the switch hardware and operating system. The examples that are provided for the S4048T-ON are running the OS9 or OS10 operating system. Separate VLANs could be configured to manage different types of equipment based on your requirements. In this example, VLAN 10 is used for both switch and server management.
On switches running OS10, by default, Telnet is disabled, SSH is enabled, and the username and password credentials are admin/admin. The switch is accessible by default using SSH with those credentials. Changing the admin password to something more complex is recommended.
OS9 configuration
The commands in this section show how to configure the management VLAN on a Dell EMC PowerSwitch series switch with OS9 installed. For a more secure connection, SSH is enabled and Telnet is disabled.
OS9# config
OS9(conf)# ip ssh enable
OS9(conf)# username admin password admin privilege 15
OS9(conf)# no ip telnet enable (optional)
Configure the interfaces for the upstream and server connections. In this example port 1/48 is used for upstream and ports 1/1-1/4 are used for server connections. Provide an interface description, use portmode hybrid to allow tagged and un-tagged frames, and configure ports as layer 2 switchport using the switchport command.
OS9(conf)#interface tengigabitethernet 1/48
OS9(conf-if-te-1/48)# description upstream network
OS9(conf-if-te-1/48)# portmode hybrid
OS9(conf-if-te-1/48)# switchport
OS9(conf-if-te-1/48)# no shutdown
OS9(conf-if-te-1/48)# exit
OS9(conf)# interface range tengigabitethernet 1/1-1/4
OS9(conf-if-te-1/48)# description server connections
OS9(conf-if-te-1/48)# portmode hybrid
OS9(conf-if-te-1/48)# switchport
OS9(conf-if-te-1/48)# no shutdown
OS9(conf-if-te-1/48)# exit
Configure the VLAN for connections to the upstream and server connections port 1/48 is used for upstream and ports 1/1-1/4 are used for server connections in this example. Provide an interface description and apply an IP address. Tag the ports that will be part of the management VLAN.
OS9(conf)# interface vlan 10
OS9(conf-if-vl-10)# description Management VLAN
OS9(conf-if-vl-10)# ip address 192.168.1.10/24
OS9(conf-if-vl-10)# no shutdown
OS9(conf-if-vl-10)# tagged tengigabitethernet 1/1-1/4,1/48
OS10EE configuration
The commands in this section describe the steps needed to configure the management VLAN port on a Dell EMC PowerSwitch series switch with OS10EE installed. Replace the IP address with an available one for your network.
Configure the management VLAN for upstream and server connections VLAN 10 is used for upstream and server management in this example. Provide interface descriptions. Apply an IP address to the VLAN and add the VLAN to the ports.
OS10(config)# interface vlan 10
OS10(config)# description “Management VLAN”
OS10(conf-if-vl-10)# ip address 192.168.1.10/24
OS10(conf-if-vl-10)#exit
Add/apply VLAN to upstream port(s)
OS10(config)# description “upstream network”
OS10(config)# interface ethernet 1/1/48
OS10(conf-if-eth1/1/48)# switchport mode trunk
OS10(conf-if-eth1/1/48)# switchport trunk allowed vlan 10
OS10(config)# description “server connections”
OS10(config)# interface range ethernet 1/1/1-1/1/4
OS10(conf-if-eth1/1/48)# switchport mode trunk
OS10(conf-if-eth1/1/48)# switchport trunk allowed vlan 10
Show port configuration:
OS10(conf-if-eth1/1/48)# show configuration
!
interface ethernet1/1/48
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10
While some switches have SSH enabled by default (with Telnet disabled), others have Telnet enabled by default. For example, switches running OS10EE have SSH enabled and telnet disabled by default. Check the documentation for the switches you are using to find the default protocols that are enabled and the ID and password credentials for logging in. From the management station or NMS, use the SSH or Telnet application to connect to the managed device.