Home > Integrated Products > VxRail > Guides > Planning Guide—VMware Cloud Foundation 5.x on VxRail > Appendix I: Sample switch configuration settings
This set of sample syntax is for providing basic guidance on the settings that must be performed on the top-of-rack switches to configure VLANs and a switch port for a Cloud Foundation on VxRail deployment, and configuring a switch support BGP peering for the Application Virtual Network (AVN). The actual code that is required on the top-of-rack switches depends on the existing data center network infrastructure, switch operating system and routing standards.
The sample syntax highlights the following required items:
interface vlan <VxRail External Management>
no shutdown
ip address <gateway>/24
vrrp-group <id>
priority <priority>
virtual-address <virtual gateway>
interface vlan <VxRail Internal Management>
no shutdown
ipv6 mld snooping querier
interface <Host Overlay>
description
no shutdown
mtu 9216
ip address <gateway>/24
ip helper-address <DHCP server IP Address>
vrrp-group <id>
priority <priority>
virtual-address <virtual gateway>
interface ethernet <port>
no shutdown
switchport mode trunk
switchport access vlan <native vlan>
The sample syntax highlights the following required items:
interface vlan <VLAN for AVN Uplink>
no shutdown
mtu 9216
ip address <Gateway IP address for AVN uplink>
ip prefix-list <Router-ESGs route map name> permit <IP address range parameters>
router bgp <External ASN>
maximum-paths ebgp 4
router-id <External router ID>
address-family ipv4 unicast
redistribute connected route-map <Router-ESG route map name>
template external-router-to-ESG
advertisement-interval <value>
password <password saved to Edge Gateways>
timers 4 12
neighbor <IP address assigned to first Edge Gateway>
inherit template external-router-to-ESG
remote-as <ASN assigned to Edge Gateways>
no shutdown
neighbor <IP address assigned to second Edge Gateway>
inherit template external-router-to-ESG
remote-as <ASN assigned to Edge Gateways>
no shutdown