Home > Networking Solutions > Enterprise/Data Center Networking Solutions > SmartFabric OS10 Networking Solutions > Guides > Dell Networking Layer 3 Leaf-Spine Deployment and Best Practices with OS10 release 10.5.3.0.44 > Example 1 using OSPF
This example describes a leaf-spine environment using OSPF with S5248F-ON at the leaf layer and Z9264F-ON switches used at the spine layer. While the S5248F-ON configuration is shown in this section the configuration provides OSPF configuration examples to build the Layer 3 leaf-spine topology shown in Figure 13.
In Rack 1, VLAN 50 is used and devices in VLAN 50 are assigned IP addresses on the 172.16.1.0/24 network. Server 1 may specify the virtual IP address (VIP) assigned to VLAN 50 on both leaf switches, 172.16.1.254, because VRRP with VLT is configured on S528F-Leaf 1 and S5248F-Leaf 2.
Traffic is load balanced across both leaf switches. Rack 2 is configured the same as Rack 1, except VLAN 60 is used and the devices in VLAN 60 are assigned to IP addresses on the 10.60.1.0/24 network. Server 2 may specify the VLAN 60 VIP address configured on the leaf switches 10.60.1.254, as its default gateway.
The configuration commands for S5248F-Leaf 3 and S5248F-Leaf 4 are similar.
Note: On S5248F-ON switches running OS10, Telnet is disabled and SSH is enabled by default. The S5248F-ON has default credentials of admin/admin. The switch is accessible using SSH with those credentials. Changing the admin password to something more complex is recommended.
S5248F-Leaf 1 | S5248F-Leaf 2 |
enable configure terminal
hostname S5248F-Leaf1
interface mgmt 1/1/1 no IP address dhcp IP address 100.67.170.30/24 no shutdown management route 0.0.0.0/0 100.67.170.254
spanning-tree mode rstp spanning-tree rstp priority 0 | enable configure terminal
hostname S5248F-Leaf2
interface mgmt 1/1/1 no IP address dhcp IP address 100.67.170. 29/24 no shutdown management route 0.0.0.0/0 100.67.170.254
spanning-tree mode rstp spanning-tree rstp priority 4096 |
S5248F-Leaf 1 | S5248F-Leaf 2 |
interface range Ethernet 1/1/47-1/1/48 no switchport
vlt-domain 127 backup destination 100.67.170.29 discovery-interface Ethernet 1/1/47 discovery-interface ethernet 1/1/48 peer-routing | interface range Ethernet /1/47-1/1/48 no switchport
vlt-domain 127 backup destination 100.67.170.30 discovery-interface Ethernet 1/1/47 discovery-interface ethernet 1/1/48 peer-routing |
Note: In this example, the NIC for Server 1 is configured as an LACP NIC team. The IP address is 172.16.1.7/24. The VRRP VIP address, 172.16.1.254, is specified as the default gateway for Server 1.
S5248F-Leaf 1 | S5248F-Leaf 2 |
interface Vlan 50 IP address 172.16.1.1/24 no shutdown
exit vrrp version 3 interface vlan 50 vrrp-group 50 virtual-IP address 172.16.1.254 | interface Vlan 50 ip address 172.16.1.2/24 no shutdown
exit vrrp version 3 interface vlan 50 vrrp-group 50 virtual-address 172.16.1.254 |
S5248F-Leaf 1 | S5248F-Leaf 2 |
interface port channel 10 description "Server 1" switchport access vlan 50 vlt-port-channel 10 spanning-tree port type edge
interface Ethernet 1/1/1 description "Server 1" channel-group 10 mode active no shutdown | interface port channel 10 description "Server 1" switchport access vlan 50 vlt-port-channel 10 spanning-tree port type edge
interface Ethernet 1/1/1 description "Server 1" channel-group 10 mode active no shutdown |
Note: If multiple loopback interfaces exist on a system, the interface with the highest numbered IP address is used as the router ID. This configuration only uses one loopback interface.
S5248F-Leaf 1 | S5248F-Leaf 2 |
interface 1/1/53 description "Z9264F-Spine1 eth 1/1/1" no switchport IP address 192.168.1.1/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/54 description "Z9264F-Spine2 eth 1/1/1" no switchport IP address 192.168.2.1/31 ip ospf 1 area 0 no shutdown
interface loopback 0 description "Router ID" IP address 10.0.2.1/32 no shutdown | interface Ethernet 1/1/53 description "Z9264F-Spine1 eth 1/1/2" no switchport IP address 192.168.1.3/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/54 description "Z9264F-Spine2 eth 1/1/2" no switchport IP address 192.168.2.3/31 ip ospf 1 area 0 no shutdown
interface loopback 0 description "Router ID" IP address 10.0.2.2/32 no shutdown |
S5248F-Leaf 1 | S5248F-Leaf 2 |
route-map spine-leaf permit 10 match IP address prefix-list spine-leaf
ip prefix-list spine-leaf seq 10 permit 10.0.0.0/8 ge 24
ip prefix-list spine-leaf seq 20 permit 172.16.0.0/16 ge 24 | route-map spine-leaf permit 10 match IP address prefix-list spine-leaf
ip prefix-list spine-leaf seq 10 permit 10.0.0.0/8 ge 24
ip prefix-list spine-leaf seq 20 permit 172.16.0.0/16 ge 24 |
S5248F-Leaf 1 | S5248F-Leaf 2 |
uplink-state-group 1 description "Disable downstream ports in event all uplinks fail"
downstream port channel 10 upstream Ethernet 1/1/53 upstream ethernet 1/1/54 enable
| uplink-state-group 1 description "Disable downstream ports in event all uplinks fail"
downstream port channel 10 upstream Ethernet 1/1/53 upstream ethernet 1/1/54 enable |
S5248F-Leaf 1 | S5248F-Leaf 2 |
router ospf 1 redistribute connected route-map spine-leaf
| router ospf 1 redistribute connected route-map spine-leaf
|
To configure BFD for OSPF:
S5248F-Leaf 1 | S5248F-Leaf 2 |
Bfd enable Router ospf 1 bfd all-neighbors
end write memory | Bfd enable Router ospf 1 bfd all-neighbors
end write memory |
Note: Establish BFD sessions with OSPFv2 neighbors on Leaf 2,3,4, Spine 1 and Spine 2.
Note: By default, OSPF uses the following BFD parameters for its neighbors: min_tx = 200 msec, min_rx = 200 msec, multiplier = 3, role = active. If BFD is configured under interface context it will be given high priority.
Note: On S5248F-ON switches running OS10, Telnet is disabled and SSH is enabled by default. The S5248F-ON has default credentials of admin/admin. The switch is accessible by default using SSH with those credentials. Changing the admin password to something more complex is recommended.
To configure Z9264F-ON spine switch:
Z9264F-Spine 1 | Z9264F-Spine 2 |
enable configure terminal
hostname Z9264F-Spine1
interface mgmt 1/1/1 no IP address dhcp IP address 100.67.173.36/24 no shutdown management route 0.0.0.0/0 100.67.173.254 | enable configure terminal
hostname Z9264F-Spine2
interface mgmt 1/1/1 no IP address dhcp IP address 100.67.173.35/24 no shutdown management route 0.0.0.0/0 100.67.173.254
|
Note: If multiple loopback interfaces exist on a system, the interface with the highest numbered IP address is used as the router ID. This configuration only uses one loopback interface
Z9264F-Spine 1 | Z9264F-Spine 2 |
interface Ethernet 1/1/1 description "S5248F-Leaf1 eth 1/1/53" no switchport IP address 192.168.1.0/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/2 description "S5248F-Leaf2 eth 1/1/53" no switchport IP address 192.168.1.2/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/3 description "S5248F-Leaf3 eth 1/1/53" no switchport IP address 192.168.1.4/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/4 description "S5248F-Leaf4 eth 1/1/53" no switchport IP address 192.168.1.6/31 ip ospf 1 area 0 no shutdown
interface loopback 0 description "Router ID" IP address 10.0.1.1/32 no shutdown | interface Ethernet 1/1/1 description "S5248F-Leaf1 eth 1/1/54" no switchport IP address 192.168.2.0/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/2 description "S5248F-Leaf2 eth 1/1/54" no switchport IP address 192.168.2.2/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/3 description "S5248F-Leaf3 eth 1/1/54" no switchport IP address 192.168.2.4/31 ip ospf 1 area 0 no shutdown
interface Ethernet 1/1/4 description "S5248F-Leaf4 eth 1/1/54" no switchport IP address 192.168.2.6/31 ip ospf 1 area 0 no shutdown
interface loopback 0 description "Router ID" IP address 10.0.1.2/32 no shutdown |
Configure a route map and IP prefix-list to redistribute all loopback addresses and leaf networks via BGP or OSPF.
Z9264F-Spine 1 | Z9264F-Spine 2 |
route-map spine-leaf permit 10 match IP address prefix-list spine-leaf
ip prefix-list spine-leaf seq 10 permit 10.0.0.0/8 ge 24
ip prefix-list spine-leaf seq 20 permit 172.16.0.0/16 ge 24 | route-map spine-leaf permit 10 match IP address prefix-list spine-leaf
ip prefix-list spine-leaf seq 10 permit 10.0.0.0/8 ge 24
ip prefix-list spine-leaf seq 20 permit 172.16.0.0/16 ge 24 |
Z9264F-Spine 1 | Z9264F-Spine 2 |
router ospf 1 redistribute connected route-map spine-leaf
| router ospf 1 redistribute connected route-map spine-leaf
|
To configure BFD for OSPF:
S9264F-Spine 1 | S9264F-Spine 2 |
Bfd enable Router ospf 1 bfd all-neighbors
end write memory | Bfd enable Router ospf 1 bfd all-neighbors
end write memory |