Home > Integrated Products > vSAN Ready Nodes > White Papers > End to end vSAN deployment with RDMA > Network configuration and setup
Global Setup:
dcbx enable
!
interface vlan 55
vlan-name vSAN
no shutdown
mtu 9216
!
wred wred_ecn
random-detect color green minimum-threshold 1000 maximum-threshold 2000 drop-probability 100
random-detect color yellow minimum-threshold 500 maximum-threshold 1000 drop-probability 100
random-detect color red minimum-threshold 100 maximum-threshold 500 drop-probability 100
random-detect ecn
!
class-map type network-qos pfcdot1p3
match qos-group 3
pfc-cos 3
!
class-map type queuing Q0
match queue 0
!
class-map type queuing Q3
match queue 3
!
qos-map traffic-class 2Q
queue 0 qos-group 0-2,4-7
queue 3 qos-group 3
!
policy-map type network-qos policy_pfcdot1p3
!
class pfcdot1p3
pause
pfc-cos 3
!
policy-map type queuing policy_2Q
!
class Q0
bandwidth percent 30
!
class Q3
bandwidth percent 70
random-detect wred_ecn
!
system qos
trust-map dot1p default
!
Host Port Facing:
description vSRN
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 55-60
mtu 9216
flowcontrol receive off
flowcontrol transmit off
priority-flow-control mode on
service-policy input type network-qos policy_pfcdot1p3
service-policy output type queuing policy_2Q
ets mode on
qos-map traffic-class 2Q
spanning-tree port type edge
dcbx version ieee
Here it's an example of setup for VLTi interface (if you setup a OS 10 VLT setup):
description VLTi
no shutdown
no switchport
mtu 9216
flowcontrol receive off
flowcontrol transmit off
priority-flow-control mode on
service-policy input type network-qos policy_pfcdot1p3
service-policy output type queuing policy_2Q
ets mode on
qos-map traffic-class 2Q
dcbx version ieee